Προβλήματα στη Δομή Επιλογής

Άσκηση 7
Να μετατρέψετε τα παρακάτω τμήματα προγράμματος σε ισοδύναμα που να χρησιμοποιούν μόνο απλές εντολές ΑΝ…ΤΟΤΕ…ΤΕΛΟΣ_ΑΝ τμήμα 1

ΑΝ Χ = 3 ΤΟΤΕ
  Χ <- Χ + 7
ΑΛΛΙΩΣ
  Χ <- Χ - 3
ΤΕΛΟΣ_ΑΝ

Η συνθήκη της αλλιώς είναι η ακριβώς αντίστροφή από αυτή της ΑΝ. Εναλλακτικά θα μπορούσαμε να γράψουμε ΟΧΙ(Χ = 3)

ΑΝ Χ= 3 ΤΟΤΕ
  Χ <- Χ + 7
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ <> 3 ΤΟΤΕ
  Χ <- Χ - 3
ΤΕΛΟΣ_ΑΝ

τμήμα 2

ΑΝ Χ < 4 ΤΟΤΕ
  Χ <- Χ + 3
ΑΛΛΙΩΣ_ΑΝ Υ > 2 ΤΟΤΕ
  Χ <- Χ - 2
ΑΛΛΙΩΣ
  Χ <- Χ + 6
ΤΕΛΟΣ_ΑΝ

Κάθε καινούρια ΑΝ πρέπει να «αρνείται» τις προηγούμενες συνθήκες

ΑΝ Χ < 4 ΤΟΤΕ
  Χ <- Χ + 3
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ >= 4 ΚΑΙ Υ > 2 ΤΟΤΕ
  Χ <- Χ - 2
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ >= 4 ΚΑΙ Υ <= 2 ΤΟΤΕ
  Χ <- Χ + 6
ΤΕΛΟΣ_ΑΝ

τμήμα 3

ΑΝ Χ < 4 ΤΟΤΕ
  Χ <- Χ + 3
  ΑΝ Υ > 2 ΤΟΤΕ
    Χ <- Χ - 2
  ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
  Χ <- Χ + 6
ΤΕΛΟΣ_ΑΝ

Οι εμφωλευμένες ΑΝ, ξαναγράφονται με την βοήθεια της ΚΑΙ

ΑΝ Χ < 4 ΤΟΤΕ
  Χ <- Χ + 3
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ < 4 ΚΑΙ Υ > 2 ΤΟΤΕ
   Χ <- Χ - 2
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ >= 4 ΤΟΤΕ
  Χ <- Χ + 6
ΤΕΛΟΣ_ΑΝ

Άσκηση 8
Η διαφορά ώρας ανάμεσα στην Ελλάδα και την Ινδία είναι 3 ώρες και 30 λεπτά. Αυτό σημαίνει πως όταν στην Ελλάδα η ώρα είναι 17.00 στην Ινδία είναι 20.30. Να γίνει πρόγραμμα που θα διαβάζει σε δύο μεταβλητές (μία για την ώρα και μία για τα λεπτά) την ώρα της Ελλάδας, σε 24ώρη μορφή, και θα εμφανίζει την ώρα της Ινδίας. π.χ. Ώρα Ελλάδας: 23.45, Ώρα Ινδίας: 3.15

ΠΡΟΓΡΑΜΜΑ Αλλαγή_ώρας
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ωρα_Ελλάδας, Λεπτά_Ελλάδας, Ωρα_Ινδίας, Λεπτά_Ινδίας, ώρα_ελλάδας_μόνο_σε_λεπτά, ώρα_ινδίας_μόνο_σε_λεπτά
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Ωρα_Ελλάδας, Λεπτά_Ελλάδας
  ώρα_ελλάδας_μόνο_σε_λεπτά <- Ωρα_Ελλάδας* 60 + Λεπτά_Ελλάδας
  ώρα_ινδίας_μόνο_σε_λεπτά <- ώρα_ελλάδας_μόνο_σε_λεπτά + 3* 60 + 30
  Ωρα_Ινδίας <- ώρα_ινδίας_μόνο_σε_λεπτά div 60
  ΑΝ Ωρα_Ινδίας > 23 ΤΟΤΕ
    Ωρα_Ινδίας <- Ωρα_Ινδίας - 24
  ΤΕΛΟΣ_ΑΝ
  Λεπτά_Ινδίας <- ώρα_ινδίας_μόνο_σε_λεπτά mod 60
  ΓΡΑΨΕ Ωρα_Ινδίας, ":", Λεπτά_Ινδίας
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ