Προβλήματα στη Δομή Επανάληψης

Άσκηση 1
Να γίνει αλγόριθμος που να εμφανίζει όλους τους αριθμούς από το 1 έως το 100 που έχουν ακριβώς 5 διαιρέτες.

Αλγόριθμος Διαιρέτες
   ! Ψάξε όλους τους υποψήφιους αριθμούς από το 1 μέχρι το 100...
   Για x από 1 μέχρι 100
      ! Για κάθε αριθμό x βρες το πλήθος των διαιρετών
      πλήθος_διαιρετών <- 0
      Για y από 1 μέχρι x
         Αν x mod y = 0 τότε
               πλήθος_διαιρετών <- πλήθος_διαιρετών + 1
         Τέλος_αν
      Τέλος_επανάληψης
      ! Αν το πλήθος διαιρετών του αριθμού x είναι 5, εμφάνισε τον αριθμό x
      Αν πλήθος_διαιρετών = 5 τότε
         Εμφάνισε x
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος Διαιρέτες

Άσκηση 2
Σε μια πιτσαρία η χρέωση της πίτσας που θα παραγγείλετε εξαρτάται από τα υλικά που θα βάλετε, σύμφωνα με τον παρακάτω πίνακα:

Πίτσα (κασέρι) 5€
Τυρί (φέτα) 1€
Ντομάτα 0,50€
Μανιτάρια 0,50€
Πιπεριές 0,50€
Καλαμπόκι 0,20€
Ελιές 0,20€

Να γίνει πρόγραμμα που θα ζητάει από το χρήστη

  • Πόσες πίτσες θέλει να παραγγείλει
  • Για κάθε μία ποια υλικά επιθυμεί. (δλδ θα ρωτάει τον χρήστη ποιο υλικό επιθυμεί και μετά αν έχει τελειώσει την παραγγελία)
  • Να υπολογίζει την συνολική χρέωση

Το πρόγραμμα δεν χρειάζεται να ελέγχει την εγκυρότητα των τιμών που διαβάζει. Να θεωρήσετε ότι τα υλικά γράφονται με πεζά γράμματα και οι απαντήσεις του χρήστη με κεφαλαία.

Παράδειγμα:
Πόσες πίτσες θα παραγγείλετε; 
2
Πίτσα #1
Θέλετε κάποιο υλικό ? 
ΝΑΙ
Εισάγετε το υλικό:
Μανιτάρια
Θέλετε κάποιο άλλο υλικό ?
ΟΧΙ
Πίτσα #2 
Θέλετε κάποιο υλικό ?
ΝΑΙ
Εισάγετε το υλικό:
Ντομάτα
Θέλετε κάποιο άλλο υλικό ?
ΝΑΙ
Εισάγετε το υλικό:
ελιές
Θέλετε κάποιο άλλο υλικό ?
ΟΧΙ
Η συνολική σας χρέωση είναι 11,20 ευρώ
ΠΡΟΓΡΑΜΜΑ πίτσα
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: i, τμχ
   ΠΡΑΓΜΑΤΙΚΕΣ: ποσό
   ΧΑΡΑΚΤΗΡΕΣ: απάντηση, υλικό
ΑΡΧΗ
   ! Αρχικά μηδενίζουμε το πληρωτέο ποσό
   ποσό <- 0
 
   ΓΡΑΨΕ 'Πόσες πίτσες θα παραγγείλετε;'
   ΔΙΑΒΑΣΕ τμχ
 
   ! Ξεκινάμε μια επανάληψη τόσες φορές όσες είναι και οι πίτσες. 
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ τμχ
 
      ! Κάθε πίτσα κοστίζει 5 ευρώ. Επομένως αύξησε το πληρωτέο ποσό κατά 5
      ποσό <- ποσό + 5
      ΓΡΑΨΕ 'Πίτσα #', i
 
      ΓΡΑΨΕ 'Θέλετε κάποιο υλικό;'
      ΔΙΑΒΑΣΕ απάντηση
      ! Ξεκίνα μια δεύτερη επανάληψη για τα υλικά της κάθε πίτσας
      ! Ο αριθμός των υλικών είναι άγνωστος, για το λόγο ΔΕΝ χρησιμοποιώ εντολή ΓΙΑ
      ΟΣΟ απάντηση <> 'ΟΧΙ' ΕΠΑΝΑΛΑΒΕ
         ΓΡΑΨΕ 'Εισαγετε το υλικό:'
         ΔΙΑΒΑΣΕ υλικό
         ! Ανάλογα με το υλικό που διαβάσαμε, αυξάνουμε το πληρωτέο ποσό
         ΕΠΙΛΕΞΕ υλικό
         ΠΕΡΙΠΤΩΣΗ 'τυρί'
            ποσό <- ποσό + 1
         ΠΕΡΙΠΤΩΣΗ 'ντομάτα', 'πιπεριές', 'μανιτάρια' 
            ποσό <- ποσό + 0,50
         ΠΕΡΙΠΤΩΣΗ 'καλαμπόκι', 'ελιές'
            ποσό <- ποσό + 0,20
         ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
 
         ΓΡΑΨΕ 'Θέλετε κάποιο άλλο υλικό;'
         ΔΙΑΒΑΣΕ απάντηση
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
   ΓΡΑΨΕ 'Η συνολική σας χρέωση είναι ', ποσό, ' ευρώ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 3
Να γίνει αλγόριθμος, πυ θα διαβάζει μία πρόταση, χαρακτήρα προς χαρακτήρα, και θα εμφανίζει:

  • Πόσοι πεζοί χαρακτήρες εισήχθησαν
  • Πόσοι κεφαλαίοι χαρακτήρες εισήχθησαν
  • Πόσοι αριθμοί εισήχθησαν Μια πρόταση τελειώνει όταν ο χρήστης καταχωρήσει τον χαρακτήρα ‘.’
Αλγόριθμος πρόταση
   πεζά <- 0
   κεφαλαία <- 0
   αριθμοί <- 0
   Αρχή_επανάληψης
      Διάβασε χαρακτήρας
      Αν χαρακτήρας >= "Α" ΚΑΙ χαρακτήρας <= "Ω" τότε
         κεφαλαία <- κεφαλαία + 1
      Αλλιώς_αν χαρακτήρας >= "α" ΚΑΙ χαρακτήρας <= "ω" τότε
         πεζά <- πεζά + 1
      Αλλιώς_αν χαρακτήρας >= "0" ΚΑΙ χαρακτήρας <= "9" τότε
         αριθμοί <- αριθμοί + 1
      Τέλος_αν
   Μέχρις_ότου χαρακτήρας = "."
   Εμφάνισε κεφαλαία, πεζά, αριθμοί
Τέλος πρόταση